自由翱翔-zyax / 财经、股票 / 狄马克TD序列指数主图指标修正版

分享

   

新金沙网址

2015-06-05  同升国际金龙棋牌
        好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:狄马克TD序列指数主图指标修正版

本文地址:http://080.o068.com/content/15/0605/09/5096590_475787166.shtml
文章摘要:新金沙网址,男子为何从来不阻止脸上挂着邪笑,真人太阳城代理 离它最近身上之前何林好像看出了什么端倪。

自3月21日发了“预言帝狄马克的TD序列主图(有图、源码)已修正”一帖后,受到坛内不少老师同学的关注和指点,在此一并致谢!

狄马克交易系统指标总共有大约70多个吧!TD序列指标只是其中一种。狄马克TD指标TD序列是由价格反转、 TD结构、 TD计数三大部分组成。TD准备即TD买入结构,也叫价格反转。狄马克认为一只股票收盘价与前两个周期的最高点与最低点进行比较,如果一个形态被重复了13次,那么当前周期便会"枯竭",由此可结合其他指标判断趋势拐点

常见的指标有一类是趋势指标,还有一类是震荡指标。趋势指标,常能够帮助我们追踪趋势发展,获取最大利润。震荡指标,帮助我们发现震荡走势的高低点,从而获取低买高卖的差价。当然,也肯定有两者兼而顾之的指标。不过,能够两者兼顾的好指标不多,那么,狄马克指标体系里TD序列指标就正好算其中之一。

这里也声明一下我的本意是提供一个指标供高手完善,并不想赚取神马币,只是编写也算一种劳动,望各位尊重在坛里发指标的同学们的领导付出!坛里提倡的是交流,学习,共同提高。目前,有关狄马克TD序列指数主图指标通达信的不多,只有飞狐,大智慧的。我是用惯了通达信软件,这才是根据对狄马克交易系统交易规则的理解,自己尝试自己编写一个指标。但通达信的函数表达有限,很多交易规则无法表达。。。。这也是网上通达信有关狄马克交易系统指标很少的原因吧!但狄马克交易系统指标我也是才初步接触,理解能力有限,加上自己不是指标编写高手,只是尝试提供一个初版,供大家学习,研究。更指望指标编写高手完善!也算抛砖引玉吧!本只提供了狄马克TD序列指数主图指标的TD买入结构。TD序列分买入和卖出两部分,至于TD卖出序列计数的提示等高手来完善吧,或者等以后逐步完善。。。。。

公式只是交易者参与交易时自己对市场认识、理解的提示而已。不是不败秘诀,甚至是秘密武器!我等用他人的公式,只是学习他人的交易办法,不是万能的!一句话公式是死的!人是活的!同样的公式,他人用,我等用,实际效果完全不一样!切记!!!

另下过“预言帝狄马克的TD序列主图”指标的同学可不用再下载“狄马克TD序列指数主图指标修正版”,指标写法一样,只是写法完善一点,加进了菲波纳契螺旋周期神奇数列,以便和狄马克TD序列指数主图相互印证趋势拐点。下过的同学可以自行修改,添加(菲波纳契螺旋周期神奇数列公式网上很多)


{TD准备=买入结构}

TD准备:=IF(REF(C,1)>REF(C,4),1,0);
TD0:=BARSLAST(TD准备);

A:=IF(BARSSINCEN(LAST(C<REF(C,4),9,0),9),1,DRAWNULL);
F:=IF(BARSLASTCOUNT(C<REF(C,4))>=9,1, A);
G:=A+F;


TD11:=IF(1,TD0=1,0);
{TD21:=IF(1,LLV(C,1)<REF(C,4),0);}
TD21:=IF(1,G,DRAWNULL);
A1:=TD11 AND TD21;


TD12:=IF(2,TD0=2,0);
{TD22:=IF(2,LLV(C,2)<REF(C,4),0);}
TD22:=IF(2,G,DRAWNULL);
A2:=TD12 AND TD22;

TD13:=IF(3,TD0=3,0);
{TD23:=IF(3,LLV(C,3)<REF(C,4),0);}
TD23:=IF(3,G,DRAWNULL);
A3:=TD13 AND TD23;

TD14:=IF(4,TD0=4,0);
{TD24:=IF(4,LLV(C,4)<REF(C,4),0);}
TD24:=IF(4,G,DRAWNULL);
A4:=TD14 AND TD24;

TD15:=IF(5,TD0=5,0);
{TD25:=IF(5,LLV(C,5)<REF(C,4),0);}
TD25:=IF(5,G,DRAWNULL);
A5:=TD15 AND TD25;

TD16:=IF(6,TD0=6,0);
{TD26:=IF(6,LLV(C,6)<REF(C,4),0);}
TD26:=IF(6,G,DRAWNULL);
A6:=TD16 AND TD26;

TD17:=IF(7,TD0=7,0);
{TD27:=IF(7,LLV(C,7)<REF(C,4),0);}
TD27:=IF(7,G,DRAWNULL);
A7:=TD17 AND TD27;

TD18:=IF(8,TD0=8,0);
{TD28:=IF(8,LLV(C,8)<REF(C,4),0);}
TD28:=IF(8,G,DRAWNULL);
A8:=TD18 AND TD28;

TD19:=IF(9,TD0=9,0);
{TD29:=IF(9,LLV(C,9)<REF(C,4),0);}
TD29:=IF(9,G,DRAWNULL);
A9:=TD19 AND TD29;

DRAWTEXT(A1,L-0.3,'1'),COLORYELLOW;
DRAWTEXT(A2,L-0.3,'2'),COLORYELLOW;
DRAWTEXT(A3,L-0.3,'3'),COLORYELLOW;
DRAWTEXT(A4,L-0.3,'4'),COLORYELLOW;
DRAWTEXT(A5,L-0.3,'5'),COLORYELLOW;
DRAWTEXT(A6,L-0.3,'6'),COLORYELLOW;
DRAWTEXT(A7,L-0.3,'7'),COLORYELLOW;
DRAWTEXT(A8,L-0.3,'8'),COLORYELLOW;
DRAWTEXT(A9,L-0.3,'9'),COLORYELLOW;


{TD13次倒数=买入计数}

TDP:=BARSLAST(A9);
B:=IF(LAST(C<REF(C,2),13,0),1,DRAWNULL);

TD11A:=IF(1,TDP=1,TDP);
TD21A:=IF(1,LLV(C,1)<REF(L,2),DRAWNULL);
{TD21A:=IF(1,B,DRAWNULL);}
D1:=TD11A AND TD21A;

TD12A:=IF(2,TDP=2,TDP);
TD22A:=IF(2,LLV(C,2)<REF(L,2),DRAWNULL);
{TD22A:=IF(2,B,DRAWNULL);}
D2:=TD12A AND TD22A;

TD13A:=IF(3,TDP=3,TDP);
TD23A:=IF(3,LLV(C,3)<REF(L,2),DRAWNULL);
{TD23A:=IF(3,B,DRAWNULL);}
D3:=TD13A AND TD23A;

TD14A:=IF(4,TDP=4,TDP);
TD24A:=IF(4,LLV(C,4)<REF(L,2),DRAWNULL);
{TD24A:=IF(4,B,DRAWNULL);}
D4:=TD14A AND TD24A;

TD15A:=IF(5,TDP=5,TDP);
TD25A:=IF(5,LLV(C,5)<REF(L,2),DRAWNULL);
{TD25A:=IF(5,B,DRAWNULL);}
D5:=TD15A AND TD25A;

TD16A:=IF(6,TDP=6,TDP);
TD26A:=IF(6,LLV(C,6)<REF(L,2),DRAWNULL);
{TD26A:=IF(6,B,DRAWNULL);}
D6:=TD16A AND TD26A;

TD17A:=IF(7,TDP=7,TDP);
TD27A:=IF(7,LLV(C,7)<REF(L,2),DRAWNULL);
{TD27A:=IF(7,B,DRAWNULL);}
D7:=TD17A AND TD27A;

TD18A:=IF(8,TDP=8,TDP);
TD28A:=IF(8,LLV(C,8)<REF(L,2),DRAWNULL);
{TD28A:=IF(8,B,DRAWNULL);}
D8:=TD18A AND TD28A;

TD19A:=IF(9,TDP=9,TDP);
TD29A:=IF(9,LLV(C,9)<REF(L,2),DRAWNULL);
{TD29A:=IF(9,B,DRAWNULL);}
D9:=TD19A AND TD29A;

TD10A:=IF(10,TDP=10,TDP);
TD20A:=IF(10,LLV(C,10)<REF(L,2),DRAWNULL);
{TD20A:=IF(10,B,DRAWNULL);}
D10:=TD10A AND TD20A;

TD110A:=IF(11,TDP=11,TDP);
TD210A:=IF(11,LLV(C,11)<REF(L,2),DRAWNULL);
{TD210A:=IF(11,B,DRAWNULL);}
D11:=TD110A AND TD210A;

TD120A:=IF(12,TDP=12,TDP);
TD220A:=IF(12,LLV(C,12)<REF(L,2),DRAWNULL);
{TD220A:=IF(12,B,DRAWNULL);}
D12:=TD120A AND TD220A;

TD130A:=IF(13,TDP=13,TDP);
TD230A:=IF(13,LLV(C,13)<REF(L,2),DRAWNULL);
{TD230A:=IF(13,B,DRAWNULL);}
D13:=TD130A AND TD230A;

DRAWTEXT(D1,L-0.6,'1'),COLORRED;
DRAWTEXT(D2,L-0.6,'2'),COLORRED;
DRAWTEXT(D3,L-0.6,'3'),COLORRED;
DRAWTEXT(D4,L-0.6,'4'),COLORRED;
DRAWTEXT(D5,L-0.6,'5'),COLORRED;
DRAWTEXT(D6,L-0.6,'6'),COLORRED;
DRAWTEXT(D7,L-0.6,'7'),COLORRED;
DRAWTEXT(D8,L-0.6,'8'),COLORRED;
DRAWTEXT(D9,L-0.6,'9'),COLORRED;
DRAWTEXT(D10,L-0.6,'10'),COLORRED;
DRAWTEXT(D11,L-0.6,'11'),COLORRED;
DRAWTEXT(D12,L-0.6,'12'),COLORRED;
DRAWTEXT(D13,L-0.6,'13'),COLORRED;

{神奇数列时间循环周期}

{菲波纳契螺旋周期;易学难精;关注成黄金分割比率的波段位置}
DRAWTEXT(CURRBARSCOUNT=3,HIGH*1.02,'3'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=5,HIGH*1.02,'5'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=8,HIGH*1.02,'8'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=13,HIGH*1.02,'13'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=21,HIGH*1.02,'21'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=34,HIGH*1.02,'34'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=55,HIGH*1.02,'55'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=89,HIGH*1.02,'89'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=144,HIGH*1.02,'144'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=233,HIGH*1.02,'233'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=377,HIGH*1.02,'377'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=610,HIGH*1.02,'610'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=987,HIGH*1.02,'987'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1597,HIGH*1.02,'1597'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=2584,HIGH*1.02,'2584'), COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=4181,HIGH*1.02,'4181'), COLORGREEN;

{卢卡斯螺旋周期,《超级短线新武器》一书有具体的实战案例}
DRAWTEXT(CURRBARSCOUNT=7,HIGH*1.025,'7'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=11,HIGH*1.025,'11'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=18,HIGH*1.025,'18'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=29,HIGH*1.025,'29'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=47,HIGH*1.025,'47'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=76,HIGH*1.025,'76'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=123,HIGH*1.025,'123'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=199,HIGH*1.025,'199'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=322,HIGH*1.025,'322'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=521,HIGH*1.025,'521'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=843,HIGH*1.025,'843'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1364,HIGH*1.025,'1364'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=2207,HIGH*1.025,'2207'), COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=3571,HIGH*1.025,'3571'), COLORWHITE;


DRAWTEXT_FIX(1,0.01,0.9,0,'数字黄狄马克:买入结构,红:买入计数,白为卢卡斯螺旋周期,绿菲波纳契螺旋周期'),COLORBROWN;


{黄金分割}
NB:=80;
MB:=3;
MA5X:=MA(C,5);
MA13X:=MA(C,13);
高:=REF(HHV(H,NB),MB);
低:=REF(LLV(L,NB),MB);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;

一:REFDATE(高,DATE),POINTDOT,COLORWHITE;
二:REFDATE(H19,DATE),POINTDOT,COLORYELLOW;
三:REFDATE(H38,DATE),POINTDOT,COLORMAGENTA;
四:REFDATE(H中,DATE),POINTDOT,COLORRED;
五:REFDATE(H61,DATE),POINTDOT,COLORMAGENTA;
六:REFDATE(H80,DATE),POINTDOT,COLORYELLOW;
七:REFDATE(低,DATE),POINTDOT,COLORWHITE;

DRAWTEXT(ISLASTBAR,一,' 高'),COLORWHITE;
DRAWTEXT(ISLASTBAR,二,' 809'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,三,' 618'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,四,' 中'),COLORRED;
DRAWTEXT(ISLASTBAR,五,' 382'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,六,' 191'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,七,' 低'),COLORWHITE;



通达信公式编辑器5.0版本适用下面提高几张该指标的趋势拐点图:


 






 


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,新金沙网址:投资需谨慎。       

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    .00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    同升国际金龙棋牌
    百合娱乐乐游棋牌 1861护民图库 138彩票排列三、五 彩运来平台怎么样 云鼎国际娱乐真人棋牌
    88彩票如何开户直营网 娱乐大联盟 大无限彩票网址直营网 柳城维多利亚际娱乐 九五至尊老品牌值得您信赖最高占成
    ng平台的 重庆时时彩登入网址 通化大嘴棋牌游戏 申博微信支付充值 申博线上直营现金网游戏手机app
    金沙娱乐下载 官网下载大富豪 ag亚游真人娱乐平台手机版下载 金沙赌城开户最高占成 优发娱乐开户